Skip to main content

Using the FACE CARTOONIZER

REQUIREMENTS:
  • Photoshop CC, CS6, CS5, CS4, CS3
  • Photoshop Elements 15 or newer
SKILLS LEVEL:
  • Easy

The following video tutorial shows you how to use the Face Cartoonizer AI-powered add-on for the latest versions of Adobe Photoshop.

COMPLETE PanosFX - empower your creativity!

Get the entire collection of PanosFX add-ons for Adobe Photoshop and Photoshop Elements,  at a fraction of their combined value!

And there's more:

  • You get every new product and updates for the next 12 months!
  • You get 50% off, if you wish to renew your yearly license.